Pocket
LINEで送る

Python Wheels
http://pythonwheels.com/

パッケージの形態っぽい。昔はEggというのが主流の形態でしたが、古くなったのでwheelに変わったらしい。wheelパッケージのインストール方法を知りたい。あとpipというのはyumみたいな感じのやつっぽいから入れて使えるようにしてみる。wheelパッケージはpipを使えばインストールできるらしい。

pip

mac(10.10.5)を使ってますが、下記でインストールできた。

$ easy_install pip

pipでwheelをインストール

$ pip install Pillow-2.9.0-cp27-none-macosx_10_6_intel.macosx_10_9_intel.macosx_10_9_x86_64.macosx_10_10_intel.macosx_10_10_x86_64.whl

You are using pip version 7.0.3, however version 7.1.2 is available.
You should consider upgrading via the ‘pip install –upgrade pip’ command.
Pillow-2.9.0-cp27-none-macosx_10_6_intel.macosx_10_9_intel.macosx_10_9_x86_64.macosx_10_10_intel.macosx_10_10_x86_64.whl is not a supported wheel on this platform.

エラーがでた。

$ pip install --upgrade pip

まだ、サポートしてないといわれている。なぜだ。python3.4だからかな。Pillow-2.9.0-cp34-cp34m-macosx_10_6_intel.macosx_10_9_intel.macosx_10_9_x86_64.macosx_10_10_intel.macosx_10_10_x86_64.whl (md5)か。

$ pip install Pillow-2.9.0-cp34-cp34m-macosx_10_6_intel.macosx_10_9_intel.macosx_10_9_x86_64.macosx_10_10_intel.macosx_10_10_x86_64.whl

まだ言われる。

$ python3
>>> import distutils.util
>>> distutils.util.get_platform()
'macosx-10.5-x86_64'

これでプラットフォームのタイプを取得できた。

どうも、anacondaだとダメらしい。
参考:https://github.com/Homebrew/homebrew-python/issues/172

condaというコマンドでインストールできるらしい。

$ conda install pillow

pillow2.9がインストールできた。

Pocket
LINEで送る

カテゴリー: プログラミング

コメントください

関連記事

プログラミング

Go言語によるビットコインのフルノード実装btcdを調べる(2)

btcdを実行した際のプログラムの流れを最初から確認してみます。 se 続きを読む …

プログラミング

Go – leveldb

Goで使えるLevelDB。 syndtr/goleveldb ドキュ 続きを読む …

%d人のブロガーが「いいね」をつけました。